959 Wiadomości w 116 wątkach, - wysłana przez 106 użytkowników - Najnowszy użytkownik: Kamilbsg

Autor Wątek: Polcoin-core 1.5.1.0 wydany  (Przeczytany 3183 razy)

pdrobek

  • KGW
  • Zaawansowany użytkownik
  • *
  • Wiadomości: 358
  • Reputacja +6/-0
    • Zobacz profil
Odp: Polcoin-core 1.5.1.0 wydany
« Odpowiedź #15 dnia: Listopad 24, 2016, 08:31:55 pm »
Mam problem, nie mogę odpalić na maszynie z debianem - przyznam szczerzę, że po raz pierwszy coś takiego mi się przytrafiło.

Wywala mi się już na autogen.sh
aclocal: couldn't open directory 'build-aux/m4': Nie ma takiego pliku ani katalogu
autoreconf: aclocal failed with exit status: 1

Debian wheezy x64.

Podeślij mi kompletny log z kompilowania, ekstra poproszę o listę pakietów zainstalowanych w systemie.

chmielo

  • PLC
  • Nowy użytkownik
  • *
  • Wiadomości: 29
  • Reputacja +1/-0
    • Zobacz profil
Odp: Polcoin-core 1.5.1.0 wydany
« Odpowiedź #16 dnia: Listopad 26, 2016, 01:07:29 pm »
Poradziłem sobie - upgrade do 8 i po temacie. Odkładałem ten upgrade ile się dało, ale w końcu się zmotywowałem.

Mam inny problem, mianowicie na trzech maszynach przy synchronizacji wywala mi coś takiego:


2016-11-26 11:00:34 Opened LevelDB successfully
2016-11-26 11:00:35 Gensis pass
2016-11-26 11:00:42 LoadBlockIndexDB: last block file = 2
2016-11-26 11:00:42 LoadBlockIndexDB: last block file info: CBlockFileInfo(blocks=236659, size=112653692, heights=516828...753486, time=2015-09-04...2016-02-28)
2016-11-26 11:00:42 Checking all blk files are present...
2016-11-26 11:00:42 LoadBlockIndexDB(): transaction index disabled
2016-11-26 11:00:42 LoadBlockIndexDB(): hashBestChain=000000000000276a0a8fafda6e749ebfe1b1cb66887e34a0fb3649d386f15e53 height=753486 date=2016-02-28 19:12:00 progress=0.803071
2016-11-26 11:00:42 init message: Verifying blocks...
2016-11-26 11:00:42 Verifying last 288 blocks at level 3
2016-11-26 11:00:42 No coin database inconsistencies in last 289 blocks (300 transactions)
2016-11-26 11:00:42  block index            8432ms
2016-11-26 11:00:42 init message: Loading wallet...
2016-11-26 11:00:42 nFileVersion = 1050100
2016-11-26 11:00:42 Keys: 101 plaintext, 0 encrypted, 101 w/ metadata, 101 total
2016-11-26 11:00:42  wallet                   66ms
2016-11-26 11:00:42 mapBlockIndex.size() = 971299
2016-11-26 11:00:42 nBestHeight = 753486
2016-11-26 11:00:42 setKeyPool.size() = 100
2016-11-26 11:00:42 mapWallet.size() = 0
2016-11-26 11:00:42 mapAddressBook.size() = 1
2016-11-26 11:00:42 init message: Loading addresses...
2016-11-26 11:00:42 Loaded 1 addresses from peers.dat  0ms
2016-11-26 11:00:42 addcon thread start
2016-11-26 11:00:42 init message: Done loading
2016-11-26 11:00:42 opencon thread start
2016-11-26 11:00:42 dnsseed thread start
2016-11-26 11:00:42 msghand thread start
2016-11-26 11:00:42 dumpaddr thread start
2016-11-26 11:00:42 net thread start
2016-11-26 11:00:42 receive version message: /New Epoch:1.4.0.1/: version 70001, blocks=976454, us=178.42.176.106:37151, peer=1
2016-11-26 11:00:42 Added time data, samples 2, offset -6 (+0 minutes)
2016-11-26 11:00:42 ERROR: ContextualCheckBlockHeader : rejected nVersion=2 block
2016-11-26 11:00:42 ERROR: invalid header received
2016-11-26 11:00:42 ProcessMessage(headers, 162003 bytes) FAILED peer=1
2016-11-26 11:00:43 receive version message: /Genesis pass:1.5.1/: version 70001, blocks=767689, us=178.42.176.106:51934, peer=2
2016-11-26 11:00:43 Added time data, samples 3, offset -8 (+0 minutes)
2016-11-26 11:00:53 P2P peers available. Skipped DNS seeding.
2016-11-26 11:00:53 dnsseed thread exit
2016-11-26 11:13:46 ERROR: ContextualCheckBlockHeader : rejected nVersion=2 block
2016-11-26 11:13:46 ERROR: invalid header received
2016-11-26 11:13:46 ProcessMessage(headers, 162003 bytes) FAILED peer=1
2016-11-26 11:20:02 ERROR: ContextualCheckBlockHeader : rejected nVersion=2 block
2016-11-26 11:20:02 ERROR: invalid header received
2016-11-26 11:20:02 ProcessMessage(headers, 162003 bytes) FAILED peer=1
2016-11-26 11:28:12 ERROR: ContextualCheckBlockHeader : rejected nVersion=2 block
2016-11-26 11:28:12 ERROR: invalid header received
2016-11-26 11:28:12 ProcessMessage(headers, 162003 bytes) FAILED peer=1
2016-11-26 11:29:01 ERROR: ContextualCheckBlockHeader : rejected nVersion=2 block
2016-11-26 11:29:01 ERROR: invalid header received
2016-11-26 11:29:01 ProcessMessage(headers, 162003 bytes) FAILED peer=1

pdrobek

  • KGW
  • Zaawansowany użytkownik
  • *
  • Wiadomości: 358
  • Reputacja +6/-0
    • Zobacz profil
Odp: Polcoin-core 1.5.1.0 wydany
« Odpowiedź #17 dnia: Listopad 29, 2016, 03:39:31 pm »
To jest właśnie powód braku synchronizacji, ostatnia poprawka (jeszcze nie wyeksportowana na githuba) naprawia ten problem.

wargo

  • KGW
  • Użytkownik
  • *
  • Wiadomości: 90
  • Reputacja +4/-0
    • Zobacz profil
    • Kopalnia PLC
Odp: Polcoin-core 1.5.1.0 wydany
« Odpowiedź #18 dnia: Listopad 29, 2016, 04:18:01 pm »
Chyba wymusza nowe wersje bloków.

chmielo

  • PLC
  • Nowy użytkownik
  • *
  • Wiadomości: 29
  • Reputacja +1/-0
    • Zobacz profil
Odp: Polcoin-core 1.5.1.0 wydany
« Odpowiedź #19 dnia: Listopad 29, 2016, 11:10:37 pm »
Dobra poradziłem sobie z tym. Bloki zaciągnąłem wersją 1.4.0.1 i po synchronizacji przełączyłem na 1.5.1.0 i działa bez problemu - to pod linuxem. Pod windą jeszcze tego nie testowałem.

pdrobek

  • KGW
  • Zaawansowany użytkownik
  • *
  • Wiadomości: 358
  • Reputacja +6/-0
    • Zobacz profil
Odp: Polcoin-core 1.5.1.0 wydany
« Odpowiedź #20 dnia: Listopad 30, 2016, 11:13:06 am »
Pod winde już są uaktualnione portfele na stronie polcoin.pl

rav3n_pl

  • KGW
  • Użytkownik
  • *
  • Wiadomości: 88
  • Reputacja +6/-0
    • Zobacz profil
Odp: Polcoin-core 1.5.1.0 wydany
« Odpowiedź #21 dnia: Grudzień 19, 2016, 09:58:21 pm »
Coś się spsuło:
2016-12-19 20:55:53 ERROR: invalid header received
2016-12-19 20:55:53 ProcessMessage(headers, 162003 bytes) FAILED peer=12
2016-12-19 20:55:53 ERROR: ContextualCheckBlockHeader : rejected nVersion=2 block
2016-12-19 20:55:53 ERROR: invalid header received
2016-12-19 20:55:53 ProcessMessage(headers, 162003 bytes) FAILED peer=2
2016-12-19 20:55:53 ERROR: ContextualCheckBlockHeader : rejected nVersion=2 block
2016-12-19 20:55:53 ERROR: invalid header received
2016-12-19 20:55:53 ProcessMessage(headers, 162003 bytes) FAILED peer=3
2016-12-19 20:55:53 ERROR: ContextualCheckBlockHeader : rejected nVersion=2 block
2016-12-19 20:55:53 ERROR: invalid header received
2016-12-19 20:55:53 ProcessMessage(headers, 162003 bytes) FAILED peer=6
2016-12-19 20:55:54 ERROR: ContextualCheckBlockHeader : rejected nVersion=2 block
2016-12-19 20:55:54 ERROR: invalid header received
2016-12-19 20:55:54 ProcessMessage(headers, 162003 bytes) FAILED peer=10
2016-12-19 20:55:55 ERROR: ContextualCheckBlockHeader : rejected nVersion=2 block
2016-12-19 20:55:55 ERROR: invalid header received
2016-12-19 20:55:55 ProcessMessage(headers, 162003 bytes) FAILED peer=14
2016-12-19 20:55:58 ERROR: ContextualCheckBlockHeader : rejected nVersion=2 block
2016-12-19 20:55:58 ERROR: invalid header received
2016-12-19 20:55:58 ProcessMessage(headers, 162003 bytes) FAILED peer=7
2016-12-19 20:56:00 ERROR: ContextualCheckBlockHeader : rejected nVersion=2 block
2016-12-19 20:56:00 ERROR: invalid header received
2016-12-19 20:56:00 ProcessMessage(headers, 162003 bytes) FAILED peer=13
2016-12-19 20:56:25 connect() to 194.88.155.174:9338 failed after select(): Connection refused (111)
2016-12-19 20:56:33 connect() to 78.31.153.129:9338 failed after select(): Connection refused (111)
2016-12-19 20:56:41 connect() to 69.39.239.47:9338 failed after select(): Connection refused (111)
2016-12-19 20:56:53 ERROR: AcceptToMemoryPool : nonstandard transaction: non-final
2016-12-19 20:56:55 ERROR: AcceptToMemoryPool : nonstandard transaction: non-final
2016-12-19 20:57:04 connect() to 108.61.103.113:9338 failed after select(): Connection refused (111)
2016-12-19 20:57:05 connect() to 91.228.95.248:9338 failed after select(): Connection refused (111)
Wygląda mi to na konflikt wersji - bloki v2 są nie obsługiwane a nadal kopane w "starej" wersji Polcoin. Polcoin-core je odrzuca, bo wcześniej były juz bloki z większym numerem wersji.
Piffko PLC/BTC 1Rav3nkMayCijuhzcYemMiPYsvcaiwHni :)

pdrobek

  • KGW
  • Zaawansowany użytkownik
  • *
  • Wiadomości: 358
  • Reputacja +6/-0
    • Zobacz profil
Odp: Polcoin-core 1.5.1.0 wydany
« Odpowiedź #22 dnia: Grudzień 22, 2016, 08:48:41 am »
tak dokładnie to, jestem na etapie migrowania kopalni na nowego klienta. Jakby ktoś mógł pomóc w pracach to by to prace by przyspieszyly http://polcoin:7010

brak rejestracji = user = twoj adres PLC, pass = dowolne cos

wargo

  • KGW
  • Użytkownik
  • *
  • Wiadomości: 90
  • Reputacja +4/-0
    • Zobacz profil
    • Kopalnia PLC
Odp: Polcoin-core 1.5.1.0 wydany
« Odpowiedź #23 dnia: Grudzień 22, 2016, 11:10:56 am »
Jakby ktoś mógł pomóc w pracach to by to prace by przyspieszyly http://polcoin:7010
Wydobywanie na nowej kopalni by pomogło i przyspieszyło?

pdrobek

  • KGW
  • Zaawansowany użytkownik
  • *
  • Wiadomości: 358
  • Reputacja +6/-0
    • Zobacz profil
Odp: Polcoin-core 1.5.1.0 wydany
« Odpowiedź #24 dnia: Grudzień 22, 2016, 11:54:53 am »
Ogólnie prędzej czy później trzeba będzie przejść z mpos-a na unomp (nowy silnik kopalni) gdyż konstrukcja mpos-a jest na tyle dziwna że aż trudna do serwisowania a zbliża się koniec roku. W związku z tym czyszczenie bazy i mailing :-)

Nowy silnik wg założenia ma być fail-proof co w przypadku mpos-a wymagało masę roboty aby taki stan rzeczy osiągnąć. Na chwilę obecną interfejs chodzi ale nie podłączyłem jeszcze ani jednej koparki, jednak na mailu dostałem raport że nowa kopania nie przydziela pracy do wykonania. Nie miałem czasu się tym zająć.

Próbę migracji mpos-a na polcoin-core miałem za sobą jakiś czas temu ... kopalnia przestała funkcjonować z tą wersją mpos-a. Przypomnę że wykonałem autorskie tłumaczenie na polski język. Upgrade wersji będzie znaczył utratę tłumaczenia gdyż kod mpos-a nie wspiera w sposób ludzki plików z tłumaczeniem.

Reasumując i odpowiadając na twoje pytanie "czy przyśpieszy" tego nie wiem ale znacząco uprości wygląd kopalni od strony administracyjnej jak i użytkowej (brak rejestracji)


wargo

  • KGW
  • Użytkownik
  • *
  • Wiadomości: 90
  • Reputacja +4/-0
    • Zobacz profil
    • Kopalnia PLC
Odp: Polcoin-core 1.5.1.0 wydany
« Odpowiedź #25 dnia: Grudzień 22, 2016, 03:05:07 pm »
Reasumując i odpowiadając na twoje pytanie "czy przyśpieszy" tego nie wiem ale znacząco uprości wygląd kopalni od strony administracyjnej jak i użytkowej (brak rejestracji)
Pisałeś coś o pomocy w pracach. Użytkowanie to jest ta pomoc?

pdrobek

  • KGW
  • Zaawansowany użytkownik
  • *
  • Wiadomości: 358
  • Reputacja +6/-0
    • Zobacz profil
Odp: Polcoin-core 1.5.1.0 wydany
« Odpowiedź #26 dnia: Grudzień 22, 2016, 09:29:39 pm »
tak :-) to jest właśnie pomoc a przynajmniej próba połączenia się z kopalnią i dostarczenie logów np z cgminera

chmielo

  • PLC
  • Nowy użytkownik
  • *
  • Wiadomości: 29
  • Reputacja +1/-0
    • Zobacz profil
Odp: Polcoin-core 1.5.1.0 wydany
« Odpowiedź #27 dnia: Grudzień 27, 2016, 10:11:44 pm »
Mam dziwny objaw działania portfela pod windowsem - po odpaleniu, portfel się uruchamia, ikona jest na pasku, ale okno się nie pokazuje - tak mam na windows 10 z wersją 1.4.0.1 jak i z 1.5.1.1 - myślałem, że to wina zbyt dużego pliku wallet.dat, więc go przeniosłem i stworzył mi się nowy, ale nic to nie zmieniło. Testowałem też na widnows xp ;), ale tam też mam podobnie - tzn. okno mam otwarte ale portfel zachowuje się jakby nie odpowiadał, od czasu do czasu wyświetli mi ilość monet i że się synchronizuje, ale nie mogę przejść do żadnej zakładki bo od razu mam klepsydrę tak jak przy zawieszonej aplikacji. Mam nadzieję, że w miarę sensownie to opisałem.

rav3n_pl

  • KGW
  • Użytkownik
  • *
  • Wiadomości: 88
  • Reputacja +6/-0
    • Zobacz profil
Odp: Polcoin-core 1.5.1.0 wydany
« Odpowiedź #28 dnia: Styczeń 01, 2017, 06:50:27 pm »
Jestem w dobrym forku?
polcoin-core/src/polcoin-cli getinfo
{
    "version" : 1050100,
    "protocolversion" : 70001,
    "walletversion" : 60000,
    "balance" : xxx,
    "blocks" : 971298,
    "timeoffset" : 5,
    "connections" : 13,
    "proxy" : "",
    "difficulty" : 265436.89997219,
Piffko PLC/BTC 1Rav3nkMayCijuhzcYemMiPYsvcaiwHni :)

rav3n_pl

  • KGW
  • Użytkownik
  • *
  • Wiadomości: 88
  • Reputacja +6/-0
    • Zobacz profil
Odp: Polcoin-core 1.5.1.0 wydany
« Odpowiedź #29 dnia: Styczeń 01, 2017, 07:29:12 pm »
No to sobie odpowiem:
    {
        "id" : 4,
        "addr" : "xxx",
        "addrlocal" : "91.235.254.37:9338",
        "services" : "0000000000000001",
        "lastsend" : 1483295125,
        "lastrecv" : 1483295125,
        "bytessent" : 1899,
        "bytesrecv" : 818,
        "conntime" : 1483294044,
        "pingtime" : 0.13324800,
        "version" : 70001,
        "subver" : "/Genesis pass:1.5.1/",
        "inbound" : true,
        "startingheight" : 971298,
        "banscore" : 0,
        "synced_headers" : -1,
        "synced_blocks" : -1,
        "inflight" : [
        ],
        "whitelisted" : false
    },
    {
        "id" : 5,
        "addr" : "xxx",
        "addrlocal" : "91.235.254.37:9338",
        "services" : "0000000000000001",
        "lastsend" : 1483295157,
        "lastrecv" : 1483295157,
        "bytessent" : 14376,
        "bytesrecv" : 1786138,
        "conntime" : 1483294054,
        "pingtime" : 2.66929700,
        "version" : 70001,
        "subver" : "/New Epoch:1.4.0.1/",
        "inbound" : true,
        "startingheight" : 1023869,
Stara wersja jest ponad 10`000 bloków "dalej" niż nowa...
A "firmowy" explorator jest na "starym" forku.
Piffko PLC/BTC 1Rav3nkMayCijuhzcYemMiPYsvcaiwHni :)